27 gennaio 2008

A proposito dei Mac che sarebbero User Friendly...

Dopo aver rimediato dall'ufficio un PowerMac G4 che andava in dismissione, ho deciso di dedicarci il fine settimana per provare a "giocarci un po' a casa". Più che altro vorrei farci partire OSX per giocherellarci un po'.

La macchina in questione ha due dischi IDE interni, su uno dei quali è installato MacOs 9.2.2, e un masterizzatore DVD IDE (non Apple). Utilizzandola con il system 9 non da alcun problema.

Per prima cosa inserisco il CD di installazione di Tiger, preso da un PowerMac G5, appare l'icona, lancio "installazione di Mac OS X" e primo problema... mi dice che non riesce a selezionare il Cd come disco di boot. Poco male, apro pannello di controllo, menù di avvio e seleziono a mano il disco di boot. Riavvio, e il CD di installazione parte senza problemi.

Ah.. scoperta.. i dischi di installazione del PowerMac G5 non vanno bene per l'installazione sul G4. Sicuramente è un limite al fatto che quei dischi vengono venduti in Bundle. OK, rimedio 4 CD della versione retail e provo con quelli.

Riparte OS 9, lancio il setup dal CD retail, e ottengo di nuovo l'errore che non riesce a selezionare il CD come disco di boot. Riapro il pannello di controllo, disco di avvio... e qui un nuovo problema: l'icona del CD di installazione è in grigio e non selezionabile. Al suo interno è indicata la presenza del System 10, ma non c'è verso di selezionarla come disco di boot.

Riavvio la macchina tenendo premuto C, per forzare il boot da Cd-Rom, ma nulla...

Riavvio la macchina tenendo premuto Option... Per chi non lo sapesse il Mac mostra una lista dei dischi di avvio disponibili e lo fa scegliere (come accadeva con gli Amiga 3.0 riavviando con i due tasti del mouse premuti) ma il CD non è nella lista dei dispositivi bootabili.

Mi viene il dubbio che il Mac abbia un firmware non aggiornato... e in effetti è così! Scarico l'ultima versione (G4 Firmware Update 4.2.8), leggo la procedura di installazione che prevede di tenere premuto un tastino vicino al reset fino a sentire uno strano Boing... vabbè lo faccio, firmware installato.

La situazione però non cambia... da quel disco non si boota... Mi viene il dubbio che il disco sia rovinato, lo metto in un PowerMac G5 (con OSX) e li però mi dice che è perfettamente bootabile. Nel menù di avvio l'icona non è in grigio.. è selezionabile. Questo ovviamente vale anche per il disco di setup del G5 (quello che sul G4 vede come bootabile ma che poi mi dice che non fa per lui).

Ummm... OK, provo con le cattive maniere... apro il G4 e scollego i due dischi IDE. Lo riaccendo e ora appare "la vecchia" icona del folder alternata da un punto interrogativo... OK, inserisco il CD di Tiger Retailel... e... Parte!!!

OK! Ora il setup è partito.. avanti.. avanti.. ops.. non ci sono dischi su cui installare (dopotutto gli IDE li ho dovuti scollegare)! Ok, poco male prendo un disco Firewire da 70Gb che non utilizzavo e lo collego al G4, il Setup Lo vede e mi consente di installare.

Mi dice che avrà bisogno di tutti e 4 i CD e di tenerli a portata... ok, non c'è problema... comincia a installare e dopo diversi minuti l'installazione sembra completata. E' arrivato all'ultimo Step e mi dice che è tutto OK e di riavviare. Che strano... non mi ha chiesto nessun CD oltre al primo... Forse me li chiederà dopo il reboot.. OK, rebooto...e ripare il CD!

Come il CD? Vuole rifare l'installazione da zero??? Vabbè, forse il boot da CD ha priorità sul Firewire... rebooto e tolgo il CD... Icona del Folder con il punto interrogativo...

Ummm... ma non aveva installato?

Stacco e riattacco il disco firewire... lo spengo e lo riaccendo... poi alla fine trovo la sequenza giusta: Scollegare il disco FW, spegnerlo, accenderlo e collegarlo acceso al G4... BINGO! Appare la schermata grigia del boot di OSX... gira un po' la rotellina... "Divieto di sosta". Ossia OSX ha un problema :-(

Il system non parte... ci deve essere qualche problema.... Provo di nuovo tutta la sequenza varie volte... compresa l'installazione, ma alla fine arrivo sempre a quel punto.

Ultimo tentativo disperato... apro il disco FW, tolgo il disco IDE, e lo collego direttamente al Mac internamente, lancio il CD, installo sul disco interno IDE e alla fine? Nemmeno boota....


Ricapitolando
1) Il CD Retail di Tiger non boota se ci sono dischi IDE collegati (partono loro), neanche premendo C e non è selezionabile come disco di avvio, è in grigio (Ma che significa???)
2) Il CD G5 di Tiger boota, ma ovviamente non mi fa installare
3) Una volta installato sul disco FW parte il boot ma si blocca subito
4) Una volta installato sul disco IDE interno non boota neanche

Dipo questa divertente esperienza (alla faccia della facilità di utilizzo), ho rimediato un'altro disco di installazione di Tiger (questa volta su DVD), ma la musica non cambia...

Chicca finale... dopo aver aggiornato il firmware, l'interfaccia ethernet del mac mi da problemi... non si collega più all'hub da 1Gbit, ma solo solo a quello da 100Mbit...

Anche questo è stranissimo... non si accende più la luce dell'hub, come se fosse rotta, la porta (e infatti pensavo fosse così), ma attaccandola ad un hub da 100, funziona benissimo. Per chi non lo sapesse, la porta ethernet di questo mac è (era?) a 1Gbit...

3 commenti:

Gotecki ha detto...

il CD di Tiger per PowerMac G5 non e' "l'installazione di Tiger" bensi' il ripristino del sistema di quella configurazione per G5, ovvio che non funzioni col G4 che in base alla configurazione potrebbe avere anche delle incompatibilita' con Tiger anche retail o per esempio non bootare da FW...

Se nel G4 e' stato installato un componente non Apple e l'installazione di questo e' stata fatta da personale non Apple... non esiste alcuna garanzia che tutto funzioni liscio, anzi probabilmente esistono alcune probabilita' che chi ha installato il drive non ha aggiornato il firmware PRIMA... :)

Per le info sui Mac e su cosa ci funziona dentro c'e' un sito piuttosto comodo http://www.everymac.com

ciao! ;)

Rasty ha detto...

E che te lo dico a fa'... Il Mac è una merda!!!

Massimiliano ha detto...

Che epopea... io ho un imac e sono sempre piu' convinto che sia inutile, stupido, isolato, incomprensibile, io uso windows per le cose importanti, ho buttato via i soldi!